About
Contact
Donate
Register
Log in

PSA for Firefox users
Click to go to bottom
There's currently a bug (which may or may not affect you) where all your extensions and themes are disabled, and you cannot re-enable them because they "don't meet Firefox safety criteria." DON'T DELETE YOUR EXTENSIONS, there is nothing wrong with them. Rather, if you are affected, download Firefox build 66.0.4
I'd rather use Firefox than Chrome.
I'd rather use Firefox than Chrome. And this is why you’re not getting anymore games.
bbbam04 dont quote posts directly above urs
bbbam04 dont quote posts directly above urs Ok, I’ll remember that for next time.
JokerMod
#7

The act of quoting someone is not the problem. The issue starts when you have multiple quotes, creating a quote tower. It breaks things. That aside, I gave up on Firefox because of this, and switch to Brave.
You have to be to logged in to post
Register
Username Password Email
(optional, used only to recover your password, can be added later)
×
Log in
Forgot password?
×